Síguenos

Apache Tomcat 8 y Java 7

Java 7 fue publicado hace relativamente poco, casi al mismo tiempo que ha comenzado a desarrollarse la nueva versión de Apache Tomcat 8. Por eso, todos nos preguntamos si está relacionado este inicio del desarrollo y Tomcat 8 dará soporte a Java 7 en breve.

Mark Thomas, uno de los ingenieros responsables del proyecto Apache Tomcat ha respondido una serie de cuestiones en un post de Tomcat Expert relacionadas con el tema. En definitiva, el comienzo de desarrollo de Tomcat 8 no tiene que ir ligado obligatoriamente con Java 7, si no que dependerá en gran medida de los próximos cambios en las tres especificaciones de Servlet, JavaServer Pages (JSP) y Expession Language(EL).

Cada salto de versión de Tomcat ha ido relacionado con un cambio en alguna de las tres especificaciones, en este caso, lo más probable que si Apache Tomcat 8 de soporte a Java 7 será porque será la versión mínima de Java que se espera de la nueva especificación de Servlet 3.1 (Tomcat 7 implementa Servlet 3.0).

De momento, el inicio del desarrollo de Apache Tomcat 8 ha ido encaminado a algun refactor de APIs internas. Quizá sea muy precipitado pensar en un Tomcat 8 cuando la última versión fue lanzada hace poco más de uno año (junio de 2010) y, la anterior, (Tomcat 6) en diciembre de 2006.

Java 7 está en su primera release, y no hay aún pruebas de rendimientos fiables sobre Apache Tomcat 7. El proyecto Lucene ya sufrió algún problema relacionado con la confección de los indices al usar Java 7. Además se han detectado algunos errores cuando se utiliza SSL con la autenticación de Java 7. Aún así es posible usar Java 7 con Tomcat 7, siempre y cuando se configure el motor de JSP para usar el compilador de Java 7 y siendo conscientes de las especificaciones de Java 6 para evitar problemas de portabilidad.

Vía | Tomcat Expert
Imagen | Beatriz Vanetti Ansani

Deja un comentario

Ordenar por:

0 comentario